Christine Rousselle

Do bears live in the woods? Is the pope Catholic? Is Obamacare delayed again? Yes.

It was announced today that people with pre-existing conditions do not have to enroll in an Obamacare plan until March 15. The previous deadline had been January 31, which was an extension of the previous deadline of the end of December.

The administration said it would extend the Pre-Existing Conditions Insurance Plan (PCIP), slated to end Jan. 31, until March 15.

“As part of our continuing effort to help smooth consumers’ transition into Marketplace coverage, we are allowing those covered by PCIP additional time to shop for new coverage while they receive the ongoing care and treatment they need,” Health and Human Services spokeswoman Joanne Peters said in a statement.

This is insanity.


Christine Rousselle

Christine Rousselle is a web editor with Townhall.com. Follow her on Twitter at @crousselle.

Author Photo credit: Jensen Sutta Photography