Libs_Are_UsefulIdiots Wrote:
Nov 16, 2012 6:20 PM
Well worth the read... Obamacare Is Still Vulnerable http://www.cato.org/publications/commentary/obamacare-is-still-vulnerable